Friday, 19 September 2008

Forefront for Exchange 2007 SP1 Rollup 3 Installation Issue

Let's get the technical stuff on this blog started with an issue that one of my colleagues has seen this week.

My colleague was unable to install Forefront for Exchange 2007 SP1 Rollup 3 (KB 951629) on either nodes of an Exchange 2007 CCR environment based on Windows 2008. The same rollup had successfully installed on the Hub Transport servers, though.

The error message that was received was "The data is invalid". The installer then tried to uninstall the rollup but this failed with the same error message. The net result was effectively a half-installed rollup that you cannot complete or remove. Not good. From the log files generated by the installer, the following information was seen:

17.644: Copied file: C:\Windows\system32\fscperfmonitor.dll
17.660: DoInstllation: UpdSpCommitFileQueue for FileQueue failed: 0xd
17.707: The data is invalid.
23.744: Message displayed to the user: The data is invalid.
23.744: User Input: OK
23.744: KB951629 installation did not complete. Select 'OK' to undo the changes that have been made.
29.157: Message displayed to the user: KB951629 installation did not complete. Select 'OK' to undo the changes that have been made.

Let's cut out the long story of pulling one's hair out and get straight to the solution. It's a simple solution actually. Just stop and disable the WMI service prior to installing the rollup. Once the rollup has been applied, re-enable the service and start it back up. I say disable the service because you may find it getting started again before you apply the rollup.

Credit to my colleague Richard for supplying this information.

No comments: